
General documentation and how-to guide for 
setting up and customizing Advocate.

Version 1.0

This documentation covers the installation and basic uses of Advocate. We encourage you 
to browse this PDF throughly and periodically throughout the setup process and use of 

Advocate as it often reveals answers to common questions and issues.

If you have any questions that are beyond the scope of this help file, please feel free to 
visit our support forums. Thank you!

themes.two2twelve.com/support/
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1. Getting Started

1.1. Installation

To install Advocate, unzip the file you've downloaded from ThemeForest and use one of 
the two methods listed below to upload the theme files to WordPress:

• WordPress Upload: Navigate to Appearance > Themes > Install Themes > Upload. 
Click browse, select the zipped theme folder (advocate.zip) and click “Install Now”. The 
theme will be uploaded and automatically activated.

• FTP Upload: Using your FTP program, upload the non-zipped theme folder into the / 
wp- content/themes/ folder of your WordPress install. Once uploaded, navigate to 
Appearance > Themes and under the "Available Themes" section, activate Advocate.

1.2. Homepage Setup

Once Advocate is installed, you can setup your homepage by navigating to your 
WordPress admin panel and creating a new page entitled “Home”. Next, in the Page 
Attributes box, select Home as the Template:

Lastly, to ensure your homepage is shown as your front page, navigate to Settings > 
Reading and select the option “A static page (select below)” then select the Home from 
the “Front page:” dropdown.
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1.3. Blog Setup

To setup your blog, simply create a new page in your WordPress admin named Blog. 
Next, navigate to Settings > Reading and under the Front page displays > Posts page 
option, select the newly created Blog page.

1.4. Import Demo Theme Content

There are a few easy steps you can follow in order to recreate our demo as a starting 
point for your site. Just keep in mind that this will override any customizations you have 
already done to your theme and will reset it to look exactly like our demo.

In short, you will have to import the Advocate XML file and select the custom menus as 
follows:

1. Locate the Advocate XML file (advocate.xml) included in the theme folder you’ve 
downloaded from ThemeForest. 

2. Make sure you’ve installed the WordPress import plugin (located in your WordPress 
Admin) under Tools > Import > WordPress > Install

3. Activate the Import Plugin under Plugins > Installed Plugins > WordPress Importer > 
Activate

4. Import the XML file under Tools > Import > WordPress > Browse > Upload file
5. Setup the custom menu by navigating to Appearance > Menus > Theme Locations 

and under the Advocate Menu dropdown select Main Nav.
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Your site should now look exactly like the Advocate demo (Note: It may take a few 
minutes to populate all of the content. Make sure to refresh the page and/or clear your 
browser cache).

2. Theme Features

2.1. Custom Menus

Advocate has support for a custom WordPress menu. You can use a menu to configure 
your websites main navigation.

Configuring a Custom Menu

To access the Menu's page from your Wordpress admin panel, navigate to Appearance > 
Menus. Here you can create and customize the menu that Advocate will use it it’s Main 
Navigation. Start by creating a menu as shown below:

You may now may add/edit items from your menu using the options to the left. To view 
all available widgets, click the screen options tab at the very top of the screen to 
configure your viewing options.

Once you’ve configured and saved your menu, select it in the “Theme Locations” box 
under “Advocate Menu”. this will use your newly created menu for the main navigation 
on the site.
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2.2.Theme Options

 2.2.3 General Settings

The General Settings page allows you to control site-wide settings including the logo 
that appears in the header of your site, custom analytics code for tracking web stats, 
and footer content.

 2.2.4 Homepage Options

There are several Homepage Options for this theme including the ability to hide/
customize each section for fine tuning.

 2.2.5 Style Options

Under Styling Options you can set the theme’s Link Color and Page Layout along 
with any custom CSS or Javascript you wish to include in your pages.

 2.2.6 Slider Options

Slider Options allows complete control over the homepage slider. See “1.4 Homepage 
Slider Options” for more information.

 2.2.7 Typography Options
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The typography options in Advocate allows you to change the font family, size, and 
color of the fonts used for your site’s logo (if the “text” option is selected), page 
headings and widget headings.

 2.2.8 Social Options

The social options allow you to add links to the header to various social networking 
sites.

 2.2.9 Gallery Options

Gallery options feature several settings for tweaking the layout of the gallery page 
template. These options include modifying thumbnail sizes and enabling/disabling 
certain features.

2.3.Custom Post Types

 2.3.1 Adding Events 

Events are displayed in both Calendar style and List style. To setup up your events 
page. Go to Pages >Add New. Title your page with something like 'Events' and select 
'Events' from the Template drop down in the Page Attributes sidebar box. Remember 
to add this new page to your custom menu if you want it to show up in your site's 
navigation by going to Appearance>Menu>select the page and add to menu. Click 
save when you are done.

Now you can start adding events. To add a new event go to Events > Add New. Fill in 
a Title and add your event description. Below the description box you'll find the 
Advocate Event Options box where you can add a start and end date (*Note: you 
much add start and end dates for your event to show on your homepage) and all 
of the details of your event's location. If you would like to have a google map appear 
on the page for this event just check the box to display map which will automatically 
be generated from the address you add in the event location fields. Hit publish to see 
your event appear on your designated event page that you first created as well as on 
your homepage. 
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 2.3.2 Adding Sponsors

To add sponsors to your homepage click Sponsors >Add New and then click set 
featured image to upload you sponsor's logo. Add a title if you'd like then hit publish. 
To change the order in which your sponsor's appear of to Sponsors >Sponsor Order 
and drag, drop and save to reorder.

 2.3.3 Adding Features

Features are small excerpts with icons that appear on your homepage and can be 
linked to their own individual pages. To add a feature click Features >Add New. Enter 
a title and description for your feature and select an icon from the drop down. Check 
the check box to enable linking to the feature's full description. Click publish to see 
your feature appear on your homepage.

 2.3.4 Setting Up Your Sidebars and Footer

Sidebars consist of a combination of widgets. To create your page sidebars go to 
Appearance >Widgets. On the right hand side you'll notice that you can add a 
specific sidebar that will appear in your blog and another to show up in other pages 
as well as 4 places too add widgets to your footers. Simply drag and drop widgets 
from the left side 'Available Widgets' area to the right side sidebar boxes. Once you 
have added the widgets that you want click on them to edit their settings. See 
section 3. Custom Widgets for more details on configuring your widgets.

 2.3.5 How to Create a Donate Page

To recreate our demo donation page go to Page > Add New. Title your page 
something like "Donation" then add the following short code in the description area

[section_heading]Every little bit counts[/section_heading]

[donation_options description='Please choose a donation level. Paypal and credit 
card accepted.']
[donation_option link="#" text="Donate!" amount="$5" color="green"]
[donation_option link="#" amount="$10" color="yellow"]
[donation_option link="#" amount="$15" color="orange"]
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[donation_option link="#" amount="$25" color="brown"]
[donation_option link="#" amount="$50" color="teal"]
[/donation_options]

[section_heading]More ways to help[/section_heading]

[feature_list amount="4"][/feature_list]

To change the dollar amount displayed on the button simply change dollar amount 
number that is in-between the quotation marks next to amount. 

3. Custom Widgets

Advocate includes 6 custom widgets - they can be found and added to your sidebars under 
Appearance > Widgets.

3.1. Custom Twitter Widget

The Twitter widget allows you to configure and display your latest tweets. The available 
options are:

• Title: Title of the widget
• Twitter Username: The username of the twitter user’s tweets you’d like to 

display e.g. two2twelve

• Number of Tweets to Display: Choose the number of tweets to show

3.2. Custom Flickr Widget

The Flickr widget allows you to configure and display your latest Flickr photos. The 
available options are:

• Title: Title of the widget

• Flickr ID: The Flickr ID of the user’s photos you’d like to display You can find 
your Flickr ID at idGettr.com 

• Number of Photos to Display: Choose the number of photos to show.
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3.3. Custom Reviews Widget

The Custom Reviews widget allows you to add rotating reviews into your sidebar. 
Simply drag the widget to any sidebar area, set the title and start adding reviews! The 
available options are:

• Title: Title of the widget

• Review (Unlimited) - Add/delete the reviews that will be rotated

3.4. Custom Gallery Widget

The Gallery widget allows you to configure and display images from your WordPress 
galleries. The available options are:

• Title: Title of the widget
• Album: The album of images you’d like to display
• Number: Choose the number of images to show
• Lightbox: Choose wether to open gallery images in a lightbox

3.5. Custom Video Widget

The Video widget allows you to configure and display a video from most video hosting 
site. The available options are:

• Title: Title of the widget
• Embed Code: The embed code for the video
• Short Description: A short description of the video you are displaying

3.6. Custom Location Widget

The Location widget allows you to configure and display your location and contact 
details. The available options are:
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• Title: Title of the widget
• Address: The address of your business • Email: Your contact email address
• Phone: Your phone number
• Fax: Your fax number

4. Custom Page Templates

Advocate includes 4 built-in page template styles and can be used on any individual page.

4.1. Default Template

The default template features a sidebar which can be positioned on the left or right side 
from a setting in the Advocate options panel under Style Options.

4.2. Contact Template

This template displays a contact form which is configurable through the Advocate 
options panel.

4.3. Full Width Template

This template displays a full width template so the main content spans the entire width 
of the site.

4.4. Gallery Template

This template displays images from your gallery uploads. Options for the gallery 
template are available in the Advocate options panel under Services and Galleries.

4.5. Home Template

This template displays a homepage layout. Options for the gallery template are available 
in the Advocate options panel under Homepage Options.
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5. Shortcodes

Advocate comes pre-loaded with 36 custom shortcodes that can be easily used in posts, 
pages, widgets, and any customizable content area. Additionally, all available shortcodes 
can be accessed from a  convenient one-click button on post and page edit screens.

To access the Shortcode Panel, click the “+” icon found in the content editor while adding/
editing a page or post to reveal the panel. Choose the Shortcode you wish to use and click 
“Insert”.

You can view demos of most of the available shortcodes by visiting the Advocate 
Wordpress demo and navigating to the “Shortcodes” pages.

6. Custom Gravatar

Advocate offers support for a custom Gravatar image. To replace the default Gravatar, 
replace gravatar.png with your own image in the theme /images/ folder. Upload the new 
image to your server via FTP and select the new Gravatar from the “Discussion” options 
which can be found under Settings > Discussion.

7. Internationalization/Locatlization
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Advocate is fully Internationalized (translation ready) and can support translations in more 
than one language. In the main theme folder there is an included a .pot file for use when 
translating this theme into another language. For more information on translating see:

http://codex.wordpress.org/Translating_WordPress

8. Theme Files

8.1.CSS Files

There is one CSS stylesheet in this theme which contains all of the specific stylings for 
the theme and is called styles.css location in the main theme folder.

8.2. Javascript Files

This theme imports ten Javascript files in total (though, not all five are included on every 
page).

• jQuery 1.7.1 - The main javascript framework library http://jquery.org/

• jQuery UI 1.8.14 - A library that provides various effects http://jqueryui.com/
• HTML5 Shiv - Enables HTML5 elements in older browsers https://github.com/aFarkas/

html5shiv

• Nivo Slider - A library that provides slider and gallery effect http://
nivo.dev7studios.com/

• Fancybox 1.3.4 - A library that provides lightbox functionality for screenshots http://
fancybox.net/

• Easing - Adds easing to jQuery animations http://gsgd.co.uk/sandbox/jquery/easing/

• InField Label - Field hints for contact form https://github.com/davist11/In-Field-Labels-
jQuery-Plugin

• Tipsy - A plugin for tooltips http://onehackoranother.com/projects/jquery/tipsy/ 
• Twitter - A plugin to import tweets

• Quicksand - Creates portfolio filtering effect http://razorjack.net/quicksand/

• Advocate - Custom theme-specific javascript functions 

More specifically, the Advocate (advocate.js) Javascript file adds custom effects in 
addition to activating the other aforementioned libraries. Lastly, towards the bottom of 
this file, is the code for the ajax-powered contact form.
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8.3. PSD Files

We've included several fully sliced PSD's (located in the PSD's folder) making it easy to 
find and update nearly every image used within the theme.

If you'd like to change any images within the theme, follow these simple steps:

How to Modify Images

• Open any of the included PSD files in Photoshop and make your changes

• Navigate to File > Save for Web & Devices

• Click on the slice of the element you edited, then click Save
• Towards the bottom of the file browser dialog, ensure the "slices" dropdown is 

selected on "Selected Slices"

• Save image into the images/ directory of the theme, replacing the old one

Repeat these steps for any of the other images you wish to edit.
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